Omnibus-Packages

Omni­bus ist ein Instal­ler für kom­ple­xe Soft­ware-Stacks wie Git­lab. Es bringt einen kom­plet­ten Stack mit, in Fal­le Git­lab post­gres, ruby, nginx… Das ist wun­der­bar, hat aber einen Nach­teil: Es gibt kei­ne Del­tas, auch bei kleins­ten Ände­run­gen muß der kom­plet­te Stack neu instal­liert wer­den.
Git­lab hat zwei Edi­tio­nen: Die kos­ten­pflich­ti­ge Enter­pri­se Edi­ti­on (EE) und die freie Com­mu­ni­ty Edi­ti­on (CE). gitlab.sokoll.com hat letz­te­re.
Heu­te gab es mal wie­de rein Update:

The Git­Lab EE ver­si­ons con­tain an important secu­ri­ty fix, and we stron­gly recom­mend that all Git­Lab EE instal­la­ti­ons be upgraded imme­dia­te­ly. Git­Lab CE is not affec­ted, but the ver­si­on num­bers were increa­sed to be con­sis­tent with EE ver­sio­ning.

Bei mei­ner Ver­si­on wur­de also bis auf die Ver­si­ons­num­mer gar nichts geän­dert. Aber die wur­de eben geän­dert, und das resul­tiert in:

The following packages will be upgraded:
  gitlab-ce grafana wpasupplicant
3 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 637 MB of archives.

Ca. 600MB für die Ände­rung einer Ver­si­ons­num­mer 🙂

0

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.