Minimalistic war früher anders

Auf mei­nem fet­ten Raspi4 mit 4 GB RAM lau­fen nun Zab­bix und Grafa­na. Ich möch­te mir in Grafa­na eine geren­der­te Gra­fik (als png oder jpeg) anse­hen, allein:

Goog­len bringt: Das soll so, weil Phan­tom­JS tot sei. Eine Alter­na­ti­ve wird noch gesucht. Das ist mir frei­lich ziem­lich Wum­pe, es geht um eine Instal­la­ti­on bei mir zuhau­se, nicht um ein AKW. Also instal­lie­re ich doch ein­fach Phan­tom­JS nach:

root@r4:~# apt-cache search phantomjs
phantomjs - minimalistic headless WebKit-based browser with JavaScript API

Na wun­der­bar! Ein nied­li­ches klei­nes Java­script­chen!

root@r4:~# apt install phantomjs
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  adwaita-icon-theme at-spi2-core geoclue-2.0 gtk-update-icon-cache
  hicolor-icon-theme iio-sensor-proxy libatk-bridge2.0-0 libatk1.0-0
  libatk1.0-data libatspi2.0-0 libavahi-glib1 libcairo-gobject2 libcolord2
  libcups2 libdouble-conversion1 libegl-mesa0 libegl1 libepoxy0 libevdev2
  libgbm1 libgles2 libgles2-mesa libgtk-3-0 libgtk-3-bin libgtk-3-common
  libhyphen0 libinput-bin libinput10 libmbim-glib4 libmbim-proxy libmm-glib0
  libmtdev1 libnotify4 libpcre2-16-0 libqmi-glib5 libqmi-proxy libqt5core5a
  libqt5dbus5 libqt5gui5 libqt5network5 libqt5positioning5 libqt5printsupport5
  libqt5qml5 libqt5quick5 libqt5sensors5 libqt5svg5 libqt5webchannel5
  libqt5webkit5 libqt5widgets5 librest-0.7-0 libsoup-gnome2.4-1 libwacom-bin
  libwacom-common libwacom2 libwayland-server0 libwoff1 libxcb-icccm4
  libxcb-image0 libxcb-keysyms1 libxcb-randr0 libxcb-render-util0 libxcb-util0
  libxcb-xinerama0 libxcb-xkb1 libxcomposite1 libxkbcommon-x11-0 modemmanager
  notification-daemon qt5-gtk-platformtheme qttranslations5-l10n
Suggested packages:
  colord cups-common gvfs qt5-image-formats-plugins qtwayland5
  qt5-qmltooling-plugins
The following NEW packages will be installed:
  adwaita-icon-theme at-spi2-core geoclue-2.0 gtk-update-icon-cache
  hicolor-icon-theme iio-sensor-proxy libatk-bridge2.0-0 libatk1.0-0
  libatk1.0-data libatspi2.0-0 libavahi-glib1 libcairo-gobject2 libcolord2
  libcups2 libdouble-conversion1 libegl-mesa0 libegl1 libepoxy0 libevdev2
  libgbm1 libgles2 libgles2-mesa libgtk-3-0 libgtk-3-bin libgtk-3-common
  libhyphen0 libinput-bin libinput10 libmbim-glib4 libmbim-proxy libmm-glib0
  libmtdev1 libnotify4 libpcre2-16-0 libqmi-glib5 libqmi-proxy libqt5core5a
  libqt5dbus5 libqt5gui5 libqt5network5 libqt5positioning5 libqt5printsupport5
  libqt5qml5 libqt5quick5 libqt5sensors5 libqt5svg5 libqt5webchannel5
  libqt5webkit5 libqt5widgets5 librest-0.7-0 libsoup-gnome2.4-1 libwacom-bin
  libwacom-common libwacom2 libwayland-server0 libwoff1 libxcb-icccm4
  libxcb-image0 libxcb-keysyms1 libxcb-randr0 libxcb-render-util0 libxcb-util0
  libxcb-xinerama0 libxcb-xkb1 libxcomposite1 libxkbcommon-x11-0 modemmanager
  notification-daemon phantomjs qt5-gtk-platformtheme qttranslations5-l10n
0 upgraded, 71 newly installed, 0 to remove and 0 not upgraded.
Need to get 42.7 MB of archives.
After this operation, 161 MB of additional disk space will be used.
Do you want to continue? [Y/n]

Das Ende ist nah!!!

0

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.